Page 1 of 1

Impossible to register remote phones

PostPosted: 23/02/2015, 15:16
by matteo.erba
Problem: Impossible to register remote phones, Web Zero Distance, iOS and Android outside the company’s network

More and more systems are installed in data centers or have to be accessible outside of the company’s network. In such situation the best solution is to use a domain name instead an IP address to be able to access the PBX under any circumstances.
The WMS has a security policy for SIP registrations and you may run into this problem.

Diagnosis:
Take a trace using pcap capture tool of WMS (Settings > Tools and utilities > Generate trace).
In case you get the SIP error “403 REGISTER to unknown domain”, it means you are using a not allowed domain for the connection.
The result is that you cannot register remote phones, Web Zero Distance, iOS or Android applications.
In case of Web Zero Distance you will see an "Authentication failed" error in CTIconnect
Code: Select allSIP/2.0 403 REGISTER to unknown domain
Via: SIP/2.0/UDP 192.168.1.55:33035;branch=z9hG4bK3531822045;rport=33035;received=X.X.X.X
From: "100" <sip:100@sip.mydomain.com>;tag=1834123001
To: "100" <sip:100@sip.mydomain.com>;tag=b27e1a1d33761e85846fc98f5f3a7e58.ffa6
Call-ID: 3316283210@192.168.1.55
CSeq: 2 REGISTER
Server: Wildix GW-4.1.4.28100
Content-Length: 0

Solution:
There are two options to solve this problem
Add a third level wildixin.com domain from WMP for your PBX. Wildix offers for free a wildixin.com domain for any Wildix system and the domain is allowed by default
Add your domain (e.g. pbx.mycompany.com) in WMS Settings > PBX > SIP-RTP, “SIP Domains” field, to allow the registrations to your custom domain.

We suggest using the first option since there is a free ssl certificate to bypass the https warnings and the domain is also registered in Google for the desktop sharing feature of Wildix MCU. With custom domain desktop sharing is not enabled.